Monday, January 29, 2007

AIX LVM Quick Refrence

Quick reference only. Assumed the reader is familiar with the concept of AIX LVM

Action

smitty command

Command line

Remarks

Create a VG

smitty mkvg

mkvg -y '' -s '128'


Create a LV

smitty mklv

mklv -t jfs -y ''

jfs2 is preferred

Create a filesystem

smitty crfs

crfs -v jfs -a bf=true -d -m -A

jfs2 is preferred

Resize FS

smitty chfs

chfs -a size=+


Extend a VG

smitty extendvg

extendvg ...


Reduce a VG

smitty reducevg

reducevg


Move PV data

smitty migratepv

migratepv -l


Online a vg

smitty varyonvg

varyonvg


Offline a vg

smitty varyoffvg

varyoffvg


Export a VG

smitty exportvg

exportvg


Import a VG

smitty importvg

importvg -y


Remove a filesystem

smitty rmfs

Not recommend to use CLI


Make a lvcopy

smitty mklvcopy


Mirror a LV

Remove a lvcopy

smitty rmlvcopy


Remove the mirror of a LV

Split a lvcopy

No smitty

splitlvcopy -y 1

Mirror a vg

smitty mirrorvg

mirrorvg


Unmirror a vg

smitty unmirrorvg

Not recommend to use CLI


Saturday, January 27, 2007

The World is Flat

Recently I am reading the book "The World is Flat". I am shocked by the changes of the 21 century.

Nowadays information technology shortens the distance between people. Anybody who know how to use the IT skill can join the platform and interact with others. This is so called the 'Flat World'. The author mentioned some companies start outsourcing some jobs or tasks to India, China, or other developing countries. This would reduce the cost as well as improve the efficiency. Because of a task of my company, I just communicated with a India support and completed the task. Apart from the language issue, there are no difference whether I was working with a local or a remote support. Perhaps you will find all the back end support will be in Indea, China, or somewhere you cannot imagine. Just as what the author said, the world is becoming flat.

Nevertheless, language is still a issue for me. It is not an easy task for me to speak in English with the Indian. Perhaps I still have to improve my English.

Ref: The book in Amazon

Friday, January 19, 2007

Delete multiple default gateways

  1. Obtain how many gateways
    • # odmget -q "attribute=route" CuAt

      CuAt:
      name = "inet0"
      attribute = "route"
      value = "net,-hopcount,0,,0,192.168.0.2"
      type = "R"
      generic = "DU"
      rep = "s"
      nls_index = 0

      CuAt:
      name = "inet0"
      attribute = "route"
      value = "net,-hopcount,0,,0,192.168.0.2"
      type = "R"
      generic = "DU"
      rep = "s"
      nls_index = 0
  2. If there are more than one, need to remove the excess route
    • # chdev -l inet0 -a delroute="net,-hopcount,0,,0,192.168.0.2"
      Method error (/usr/lib/methods/chginet):
      0514-068 Cause not known.
      0821-279 writing to routing socket: The process does not exist.
      route: not in table or multiple matches
      0821-207 chginet: Cannot add route record to CuAt.
  3. Then verify again
    • # odmget -q "attribute=route" CuAt

      CuAt:
      name = "inet0"
      attribute = "route"
      value = "net,-hopcount,0,,0,192.168.0.1"
      type = "R"
      generic = "DU"
      rep = "s"
      nls_index = 0

Tuesday, January 16, 2007

Set backspace in Unix console

Sometimes the backspace key doesn't work for Unix. You can custom the key by:

stty erase 

For example:

stty erase ^H

Wednesday, January 03, 2007

Two tips for AIX

Tips 1:

When performing AIX installation by a mksysb backup, remember not to perform the following steps.

  1. Trigger open firmware prompt
  2. setenv real_base 1000000
  3. reset-all
It would caused the machine boot up dead lock in firmware prompt.

Solution : Call IBM Engineer to remove card battery in order to dry the cap.

Tips 2:

When you got the message key privileged password, that means someone lock the machine by SMS.

Solution : Call IBM Engineer to remove card battery in order to dry the cap. Then trigger SMS menu and disable password feature.